RSS | ATOM | SEARCH
スポンサーサイト

一定期間更新がないため広告を表示しています

author:スポンサードリンク, category:-,
-, -
Ruby で zlibバージョン不整合?
自宅で Ruby の環境構築中。zlib.dllがないということで、gemが起動しない。

gem error

前にもこのようなことがあって、zlib.dllがセットアップされてないのが原因だったので、
またネットでzlib.dllを探すことにする。

最初は、
http://zlib.net/
http://www.winimage.com/zLibDll/index.html
ここのサイトから落としてみたんだけど、どーもバージョンが合わないのか、
セットして同じようにgemを起動してみてもエラーが消えない。
(ちなみにRuby のバージョンは1.9.2)
現在ダウンロードできる1.1.4とか1.2.5どちらもダメだった。

で、どうしたかというと、こちらのサイトに、1.2.3ってやつが置いてあり、
こちらからダウンロードしたところ、ちゃんと動くようになりました。
http://gnuwin32.sourceforge.net/packages/zlib.htm


zlib 1.2.3

環境構築にまだ敷居が高いのか、ワタシのやり方が悪いのか。

ちなみに、このあと、readline.dllにも悩まされた。

http://jarp.does.notwork.org/win32/

「こちらからダウンロードするように」あちこちで見かけるのだが、
このサイトがつながらないのだ。

これについても

http://gnuwin32.sourceforge.net/packages/readline.htm

こちらから、ダウンロードできて、問題ありませんでした。

あーよかった。
author:NaOH, category:Ruby, 23:29
comments(0), trackbacks(0)